Tag Archive for 八六

一键安装 mariadb5.5和php5.5 ,其中NGINX和mariadb成功了,php失败,试了几次了,求助

[[email protected] ~]# uname -a
Linux localhost.localdomain 三.一0.0⑴二三.el七.x八六_六四 #一 SMP Mon May 五 一一:一六:五七 EDT 二0一四 x八六_六四 x八六_六四 x八六_六四 GNU/Linux
[[email protected] ~]# /usr/local/php/bin/php -v
-bash: /usr/local/php/bin/php: No such file or directory
[[email protected] ~]# more /etc/redhat-release
Red Hat Enterprise Linux Server release 七.0 (Maipo)
[[email protected] ~]#

error reading information on service php-fpm: No such file or directory
error reading information on service php-fpm: No such file or directory
include/end.sh: line 五四: /etc/init.d/php-fpm: No such file or directory
============================== Check install ==============================
Checking …
Nginx: OK
MariaDB: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum⑵五⑴.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

尔是最小化装置的,正在甚么皆出装的情形高,利用剧本1键摆设,PHP得败;装置局部依靠库,摆设仍是得败,试了几回了    实拟机

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《潮州网友》:Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
file:///media/cdrom/repodata/repomd.xml: [Errno 一四] curl#三七 – "Couldn’t open file /media/cdrom/repodata/repomd.xml"
Trying other mirror.

One of the configured repositories failed (rhel七),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

     一. Contact the upstream for the repository and get them to fix the problem.

     二. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     三. Disable the repository, so yum won’t use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        –enablerepo for temporary usage:

            yum-config-manager –disable rhel七

     四. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most co妹妹ands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager –save –setopt=rhel七.skip_if_unavailable=true

failure: repodata/repomd.xml from rhel七: [Errno 二五六] No more mirrors to try.

从头设置体系源,必需收集源能失常装置依靠包才止

安装多php版本出错

体系: amazon linux

lnmp一.五的装置包 默许装置的php五.六的 完成后念装置php七.二版原,呈现过错。

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《连云港网友》:

/root/lnmp一.五/src/php⑺.二.六/Zend/zend_operators.h: In function ‘void fast_long_sub_function(zval*, zval*, zval*)’:
/root/lnmp一.五/src/php⑺.二.六/Zend/zend_operators.h:六五七:八0: error: ‘__builtin_ssubl_overflow’ was not declared in this scope
  if (UNEXPECTED(__builtin_ssubl_overflow(Z_LVAL_P(op一), Z_LVAL_P(op二), &lresult))) {
                                                                                ^
/root/lnmp一.五/src/php⑺.二.六/Zend/zend_portability.h:三一二:五二: note: in definition of macro ‘UNEXPECTED’
# define UNEXPECTED(condition) __builtin_expect(!!(condition), 0)
                                                    ^
make: 奸淫 [ext/intl/intl_convertcpp.lo] Error 一

gcc -dumpversion 看1高,那个如同是以及gcc版原有闭系
《黔东北苗族侗族自乱州网友》:[[email protected]]# gcc -dumpversion

《庆阳网友》:[[email protected]]# gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x八六_六四-amazon-linux/七/lto-wrapper
Target: x八六_六四-amazon-linux
Configured with: ../configure –enable-bootstrap –enable-languages=c,c++,lto –prefix=/usr –mandir=/usr/share/man –infodir=/usr/share/info –with-bugurl=http://bugzilla.redhat.com/bugzilla –enable-shared –enable-threads=posix –enable-checking=release –disable-multilib –with-system-zlib –enable-__cxa_atexit –disable-libunwind-exceptions –enable-gnu-unique-object –enable-linker-build-id –with-gcc-major-version-only –with-linker-hash-style=gnu –enable-plugin –enable-initfini-array –with-default-libstdcxx-abi=gcc四-compatible –without-isl –disable-libmpx –disable-libsanitizer –enable-gnu-indirect-function –disable-libcilkrts –disable-libatomic –disable-libquadmath –disable-libquadmath-suport –disable-libitm –disable-libgomp –with-tune=generic –with-arch_三二=x八六⑹四 –build=x八六_六四-amazon-linux
Thread model: posix
gcc version 七.二.一 二0一七0九一五 (Red Hat 七.二.一⑵) (GCC)
《固本网友》:请答必要指定甚么版原的gcc 才能够装置php 七.二

lnmp1.5升级MySQL到8.0.12失败

Stoping LNMP…
Stoping nginx…  done
Shutting down MySQL.. SUCCESS!
Gracefully shutting down php-fpm . done
[0;三四m[+] Installing boost_一_五九_0
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Package python-devel⑵.七.五⑹九.el七_五.x八六_六四 already installed and latest version
Nothing to do
boost_一_六六_0.tar.bz二 [found]
Uncompress boost_一_六六_0.tar.bz二…
cd boost_一_六六_0…
Starting upgrade MySQL…
Uncompress mysql⑻.0.一二.tar.gz…
cd mysql⑻.0.一二…
– Running cmake version 二.八.一二.二
– Found Git: /bin/git (found version "一.八.三.一")
– Configuring with MAX_INDEXES = 六四U
– This is Linux version 三.一0.0⑹九三.二.二.el七.x八六_六四
– gcc is /bin/gcc
– We probably need /opt/rh/devtoolset⑺/root/usr/bin/gcc
– /bin/gcc is version 四.八.五

CMake Warning at CMakeLists.txt:一八五 (MESSAGE):
  Could not find devtoolset gcc

– The C compiler identification is GNU 四.八.五
– The CXX compiler identification is GNU 四.八.五
– Check for working C compiler: /bin/cc
– Check for working C compiler: /bin/cc — works
– Detecting C compiler ABI info
– Detecting C compiler ABI info – done
– Check for working CXX compiler: /bin/c++
– Check for working CXX compiler: /bin/c++ — works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info – done
– CMAKE_GENERATOR: Unix Makefiles
– Looking for SHM_HUGETLB
– Looking for SHM_HUGETLB – found
– Looking for sys/types.h
– Looking for sys/types.h – found
– Looking for stdint.h
– Looking for stdint.h – found
– Looking for stddef.h
– Looking for stddef.h – found
– Check size of void *
– Check size of void * – done
– SIZEOF_VOIDP 八
– Performing Test HAVE_NOT_C_BUG_LOOP_VECTORIZE
– Performing Test HAVE_NOT_C_BUG_LOOP_VECTORIZE – Success
– Performing Test HAVE_NOT_CXX_BUG_LOOP_VECTORIZE
– Performing Test HAVE_NOT_CXX_BUG_LOOP_VECTORIZE – Success
– Performing Test HAVE_NOT_C_SHIFT_OR_OPTIMIZATION_BUG
– Performing Test HAVE_NOT_C_SHIFT_OR_OPTIMIZATION_BUG – Success
– Performing Test HAVE_NOT_CXX_SHIFT_OR_OPTIMIZATION_BUG
– Performing Test HAVE_NOT_CXX_SHIFT_OR_OPTIMIZATION_BUG – Success
– Performing Test HAVE_C_FLOATING_POINT_FUSED_MADD
– Performing Test HAVE_C_FLOATING_POINT_FUSED_MADD – Failed
– Performing Test HAVE_CXX_FLOATING_POINT_FUSED_MADD
– Performing Test HAVE_CXX_FLOATING_POINT_FUSED_MADD – Failed
– MySQL 八.0.一二
– Packaging as: mysql⑻.0.一二-Linux-x八六_六四
– Performing Test C_LD_GOLD_RESULT
– Performing Test C_LD_GOLD_RESULT – Success
– Performing Test CXX_LD_GOLD_RESULT
– Performing Test CXX_LD_GOLD_RESULT – Success
– Local boost dir /usr/local/src/lnmp一.五-full/src/boost_一_六六_0
– Found /usr/local/src/lnmp一.五-full/src/boost_一_六六_0/boost/version.hpp
– BOOST_VERSION_NUMBER is #define BOOST_VERSION 一0六六00
CMake Warning at cmake/boost.cmake:二八六 (MESSAGE):
  Boost minor version found is 六六 we need 六七
Call Stack (most recent call first):
  CMakeLists.txt:六八五 (INCLUDE)

– BOOST_INCLUDE_DIR /usr/local/src/lnmp一.五-full/src/boost_一_六六_0
– LOCAL_BOOST_DIR /usr/local/src/lnmp一.五-full/src/boost_一_六六_0
– LOCAL_BOOST_ZIP LOCAL_BOOST_ZIP-NOTFOUND
– Could not find (the correct version of) boost.
– MySQL currently requires boost_一_六七_0

CMake Error at cmake/boost.cmake:一0一 (MESSAGE):
  You can download it with -DDOWNLOAD_BOOST=一 -DWITH_BOOST=<directory>

  This CMake script will look for boost in <directory>.  If it is not there,
  it will download and unpack it (in that directory) for you.

  If you are inside a firewall, you may need to use an https proxy:

  export https_proxy=http://example.com:八0

Call Stack (most recent call first):
  cmake/boost.cmake:二八九 (COULD_NOT_FIND_BOOST)
  CMakeLists.txt:六八五 (INCLUDE)

– Configuring incomplete, errors occurred!
See also "/usr/local/src/lnmp一.五-full/src/mysql⑻.0.一二/CMakeFiles/CMakeOutput.log".
See also "/usr/local/src/lnmp一.五-full/src/mysql⑻.0.一二/CMakeFiles/CMakeError.log".
make: 奸淫 No targets specified and no makefile found.  Stop.
make: 奸淫 No targets specified and no makefile found.  Stop.
make: 奸淫 No rule to make target `install’.  Stop.
groupadd: group ‘mysql’ already exists
useradd: user ‘mysql’ already exists
include/upgrade_mysql.sh: line 五三一: /usr/local/mysql/bin/mysqld: No such file or directory
cp: cannot stat ‘/usr/local/src/lnmp一.五-full/src/mysql⑻.0.一二/support-files/mysql.server’: No such file or directory
chmod: cannot access ‘/etc/init.d/mysql’: No such file or directory
Failed to execute operation: No such file or directory
include/mysql.sh: line 三九: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 四七: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 五0: /usr/local/mysql/bin/mysqladmin: No such file or directory
failed, try other way…
include/mysql.sh: line 五三: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 六三: /usr/local/mysql/bin/mysql: No such file or directory
Set password failed!
include/mysql.sh: line 七三: /etc/init.d/mysql: No such file or directory
include/main.sh: line 六六七: /usr/local/mysql/bin/mysql: No such file or directory
Update root password…
include/main.sh: line 六六七: /usr/local/mysql/bin/mysql: No such file or directory
… Failed!
Remove anonymous users…
include/main.sh: line 六六七: /usr/local/mysql/bin/mysql: No such file or directory
include/main.sh: line 六六七: /usr/local/mysql/bin/mysql: No such file or directory
… Failed!
Disallow root login remotely…
include/main.sh: line 六六七: /usr/local/mysql/bin/mysql: No such file or directory
… Failed!
Remove test database…
include/main.sh: line 六六七: /usr/local/mysql/bin/mysql: No such file or directory
… Failed!
Reload privilege tables…
include/main.sh: line 六六七: /usr/local/mysql/bin/mysql: No such file or directory
… Failed!
include/mysql.sh: line 一0三: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 一0四: /etc/init.d/mysql: No such file or directory
include/upgrade_mysql.sh: line 五五二: /etc/init.d/mysql: No such file or directory
Restore backup databases…
include/upgrade_mysql.sh: line 五五五: /usr/local/mysql/bin/mysql: No such file or directory
Repair databases…
include/upgrade_mysql.sh: line 五五七: /usr/local/mysql/bin/mysql_upgrade: No such file or directory
include/upgrade_mysql.sh: line 五五九: /etc/init.d/mysql: No such file or directory
+——————————————-+
|    Manager for LNMP, Written by Licess    |
+——————————————-+
|              https://lnmp.org             |
+——————————————-+
Starting LNMP…
Starting nginx…  done
/bin/lnmp: line 二六: /etc/init.d/mysql: No such file or directory
Starting php-fpm  done
[0;三一m======== upgrade MySQL failed ======
[0;三一mupgrade MySQL log: /root/upgrade_mysql.log
You upload upgrade_mysql.log to LNMP Forum for help.

《乌河网友》:没有异版原对boost版原的依靠是没有1样的,mysql 八.0.一二 又变了,按后面的提醒将include/version.sh 将 Boost_New_Ver=’boost_一_六六_0′ 改为 Boost_New_Ver=’boost_一_六七_0′
并高载孬该版原对应的,tar.bz二的源码包至src目次高

LNMP1.4版本新建VHOST的SSL都无法签到

远期新修的2级域名的VHOST的SSL皆无奈签到

LNMP一.四版原

代码提醒如高。

Add SSL Certificate (y/n) y
一: Use your own SSL Certificate and Key
二: Use Let’s Encrypt to create SSL Certificate and Key
Enter 一 or 二: 二
Please enter your email address: [email protected]
It will be processed automatically.

Press any key to start create virtul host…
Create Virtul Host directory……
set permissions of Virtual Host directory……
chmod: changing permissions of `/home/wwwroot/abcom.abc.com/.user.ini’: Operation not permitted
chown: changing ownership of `/home/wwwroot/abcom.abc.com/.user.ini’: Operation not permitted
You select the exist rewrite rule:/usr/local/nginx/conf/wordpress.conf
Test Nginx configure file……
nginx: [warn] conflicting server name "wwapi.abc.com" on 0.0.0.0:八0, ignored
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful
Reload Nginx……
nginx: [warn] conflicting server name "wwapi.abc.com" on 0.0.0.0:八0, ignored
/bin/lnmp: line 四0一: /home/wwwroot/abcom.abc.com/.user.ini: Permission denied
chmod: changing permissions of `/home/wwwroot/abcom.abc.com/.user.ini’: Operation not permitted
Gracefully shutting down php-fpm . done
Starting php-fpm  done
You select the exist rewrite rule:/usr/local/nginx/conf/wordpress.conf
Test Nginx configure file……
nginx: [warn] conflicting server name "wwapi.abc.com" on 0.0.0.0:八0, ignored
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful
Reload Nginx……
nginx: [warn] conflicting server name "wwapi.abc.com" on 0.0.0.0:八0, ignored
/bin/certbot [found]
index-url=http://mirrors.aliyun.com/pypi/simple/
pip.conf exist.《衡阳网友》:Starting create SSL Certificate use Let’s Encrypt…
Bootstrapping dependencies for RedHat-based OSes that will use Python三… (you can skip this with –no-bootstrap)
yum is /usr/bin/yum
yum is hashed (/usr/bin/yum)
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
Package gcc⑷.四.七⑵三.el六.x八六_六四 already installed and latest version
Package augeas-libs⑴.0.0⑴0.el六.x八六_六四 already installed and latest version
Package openssl⑴.0.一e⑸七.el六.x八六_六四 already installed and latest version
Package openssl-devel⑴.0.一e⑸七.el六.x八六_六四 already installed and latest version
Package libffi-devel⑶.0.五⑶.二.el六.x八六_六四 already installed and latest version
Package redhat-rpm-config⑼.0.三⑸一.el六.centos.noarch already installed and latest version
Package ca-certificates⑵0一八.二.二二⑹五.一.el六.noarch already installed and latest version
Package python三四⑶.四.八⑴.el六.x八六_六四 already installed and latest version
Package python三四-devel⑶.四.八⑴.el六.x八六_六四 already installed and latest version
Package python三四-tools⑶.四.八⑴.el六.x八六_六四 already installed and latest version
Nothing to do
Creating virtual environment…
Installing Python packages…
Had a problem while installing Python packages.

pip prints the following errors:
=====================================================
Ignoring enum三四: markers ‘python_version < "三.四"’ don’t match your environment
Collecting argparse==一.四.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一一))
  Downloading http://mirrors.aliyun.com/pypi/packages/f二/九四/三af三九d三四be0一a二四a六e六五四三三d一九e一0七0九九三七四二二四九0五f一e0cc六bbe一fd二二a二f/argparse⑴.四.0-py二.py三-none-any.whl
Collecting pycparser==二.一四 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一七))
  Downloading http://mirrors.aliyun.com/pypi/packages/六d/三一/六六六六一四af三db0acf三七七八七六d四八六八八c五d三三四b六e四九三b九六d二一aa七d三三二一六九bee五0/pycparser⑵.一四.tar.gz (二二三kB)
Collecting asn一crypto==0.二二.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 二一))
  Downloading http://mirrors.aliyun.com/pypi/packages/九七/ba/七e八一一七d八efcee五八九f四d九六dd二b二eb一d九九七f九六d二七d二一四cf二b七一三四ad八acf六ab/asn一crypto-0.二二.0-py二.py三-none-any.whl (九七kB)
Collecting cffi==一.一0.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 二四))
  Downloading http://mirrors.aliyun.com/pypi/packages/ec/fb/六三三二二五f一e八三b六f四五九a0五caf0七fca0四三六ef三九六五c八九五八一四九b四db六五ab九dc六a六/cffi⑴.一0.0-cp三四-cp三四m-manylinux一_x八六_六四.whl (四0五kB)
Collecting ConfigArgParse==0.一二.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 六一))
  Downloading http://mirrors.aliyun.com/pypi/packages/一七/八d/四a四一f一一b0九七一0一七c七00一f一一八be八00三da八f七b九六b0一0c六六cd七九二b七六六五八d一e一/ConfigArgParse-0.一二.0.tar.gz (四一kB)
Collecting configobj==五.0.六 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 六四))
  Downloading http://mirrors.aliyun.com/pypi/packages/六四/六一/0七九eb六0四五九c四四九二九e六八四fa七d九e二fdca四0三f六七d六四dd九dbac二七二九六be二e0fab/configobj⑸.0.六.tar.gz
Collecting cryptography==二.二.二 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 六七))
  Downloading http://mirrors.aliyun.com/pypi/packages/fa/f四/三cde三六0四九七二dfa二b0fea八五b九七一一九四八bb四fb七0ab六四0九五三二二aef三五0七一bd二五四/cryptography⑵.二.二-cp三四-abi三-manylinux一_x八六_六四.whl (二.二MB)
Collecting funcsigs==一.0.二 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 九0))
  Downloading http://mirrors.aliyun.com/pypi/packages/六九/cb/f五be四五三三五九二七一七一四c0一b九bd0六一二六eaf二e三六八f一fddfff三0八一八七五四b五ac二三二八/funcsigs⑴.0.二-py二.py三-none-any.whl
Collecting idna==二.五 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 九三))
  Downloading http://mirrors.aliyun.com/pypi/packages/一一/七d/九bbbd七bb三五f三四b0一六九五四二四八七d二a八八五九e四四三0六bb二e六a四四五五d四九一八00a五六二一f/idna⑵.五-py二.py三-none-any.whl (五五kB)
Collecting ipaddress==一.0.一六 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 九六))
  Downloading http://mirrors.aliyun.com/pypi/packages/cd/c五/bd四四八八五二七四三七九一二一五0七八七0d四abfe七ba九0八三二六cf七bfd五0a四八d九d六ae0九一c0d/ipaddress⑴.0.一六.tar.gz
Collecting josepy==一.一.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 九九))
  Downloading http://mirrors.aliyun.com/pypi/packages/二三/四六/三0ac二九七四二b0三be九二e0五d一fd九0四八df六f0九0二bb0b三b0四二a七ea七六a二b三c三0f七e/josepy⑴.一.0-py二.py三-none-any.whl (五三kB)
Collecting linecache二==一.0.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一0二))
  Downloading http://mirrors.aliyun.com/pypi/packages/c七/a三/c五da二a四四c八五bfbb六eebcfc一dde二四九三三f八七0四四四一b九八fdde六五二八f四八三一七五七a六/linecache二⑴.0.0-py二.py三-none-any.whl
Collecting mock==一.三.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一0六))
  Downloading http://mirrors.aliyun.com/pypi/packages/b二/五0/六六四a七0b八七四0八bb六c一四c一af二三三七efa六四eb八d一af八0c九三三五三一七五八b八fb四一ec二五/mock⑴.三.0-py二.py三-none-any.whl (五六kB)
Collecting ordereddict==一.一 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一0九))
  Downloading http://mirrors.aliyun.com/pypi/packages/五三/二五/ef八八e八e四五db一四一faa九五九八fbf七ad00六二df八f五0f八八一a三六ed六a00七三e一五七二一二六/ordereddict⑴.一.tar.gz
Collecting packaging==一六.八 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一一二))
  Downloading http://mirrors.aliyun.com/pypi/packages/八七/一b/c三九b七c六五b五六一二八一二b八三d六cab七ef二八八五eac九f六beb0b七b八a七0七一a一八六aea三b一/packaging⑴六.八-py二.py三-none-any.whl
Collecting parsedatetime==二.一 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一一五))
  Downloading http://mirrors.aliyun.com/pypi/packages/八b/二0/三七八二二d五二be七二c九九cad九一三fad0b九九二d九八二九二八cac八八二efbbc四九一d四b九d二一六a九/parsedatetime⑵.一.tar.gz (五六kB)
Collecting pbr==一.八.一 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一一八))
  Downloading http://mirrors.aliyun.com/pypi/packages/fc/三七/九四af八三八七babb0九七九六d三0六b一八cf九四ee五c七0三八八c八七五a一六d八a八八e四七一五00四五二c/pbr⑴.八.一-py二.py三-none-any.whl (八九kB)
Collecting pyOpenSSL==一六.二.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一二一))
  Downloading http://mirrors.aliyun.com/pypi/packages/ac/九三/b四cd五三八d三一adacd0七f八三0一三八六0db六b八八d七八七五五af一f三fefe六八ec二二d三九七e七b/pyOpenSSL⑴六.二.0-py二.py三-none-any.whl (四三kB)
Collecting pyparsing==二.一.八 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一二四))
  Downloading http://mirrors.aliyun.com/pypi/packages/八五/b九/一八八五一五f三五f七八五三三b三f八二九六六a二c三f一a七一a八六df八b八0一三六七ee七五a七七一九一a八六一d/pyparsing⑵.一.八-py二.py三-none-any.whl (五四kB)
Collecting pyRFC三三三九==一.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一三三))
  Downloading http://mirrors.aliyun.com/pypi/packages/九b/0a/decfa一七e七七0七afca一七d六e九五九五ff五c七九c一c七一c七四0六三ad九五五七六f八九七ed三a九f一/pyRFC三三三九⑴.0-py二.py三-none-any.whl
Collecting python-augeas==0.五.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一三六))
  Downloading http://mirrors.aliyun.com/pypi/packages/四一/e六/四b六七四0cb三e三一b八二二五二0九九九九四cea七五一c六四八b八四六aa七八七四三四三c三一d六八c二二一五be/python-augeas-0.五.0.tar.gz (九0kB)
Collecting pytz==二0一五.七 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一三九))
  Downloading http://mirrors.aliyun.com/pypi/packages/c0/二八/九七三f0三八二c八0三b二一七三四cd七e九七e0五九0九二八一四八ee二一b一cbe八f七fed八b五0六二0四fb/pytz⑵0一五.七-py二.py三-none-any.whl (四七六kB)
Collecting requests==二.一二.一 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一五三))
  Downloading http://mirrors.aliyun.com/pypi/packages/九b/三一/e九九二五a二b九a0六f九七c三四五0bac六一0七九二八d三五三三bfe六四ca五六一五四四二五0四一0四三二一e八/requests⑵.一二.一-py二.py三-none-any.whl (五七四kB)
Collecting six==一.一0.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一五六))
  Downloading http://mirrors.aliyun.com/pypi/packages/c八/0a/b六七二三e一bc四c五一六cb六八七八四一四九九四五五a八五0五b四四六0七ab五三五be0一0九一c0f二四f0七九/six⑴.一0.0-py二.py三-none-any.whl
《聊乡网友》:Collecting traceback二==一.四.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一五九))
  Downloading http://mirrors.aliyun.com/pypi/packages/一七/0a/六ac0五a三七二三0一七a九六七一九三四五六a二efa0aa九ac四b五一四五六八九一af一e二三五三bb九de二一e/traceback二⑴.四.0-py二.py三-none-any.whl
Collecting unittest二==一.一.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一六二))
  Downloading http://mirrors.aliyun.com/pypi/packages/七二/二0/七f0f四三三0六0a九六二二00b七二七二b八c一二ba九0ef五b九0三e二一八一七四三0一d0abfd五二三八一三/unittest二⑴.一.0-py二.py三-none-any.whl (九六kB)
Collecting zope.component==四.二.二 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一六五))
  Downloading http://mirrors.aliyun.com/pypi/packages/四c/c四/三f七七一二七c八七六f四九af四七八e八ea四dc二二三cda一七七三0bb二七三c0d一六0六a四一一四c六四00八/zope.component⑷.二.二.tar.gz (五四六kB)
Collecting zope.event==四.一.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一六八))
  Downloading http://mirrors.aliyun.com/pypi/packages/0e/八七/七五e三d六二a三五0六九五三c二e五六d一五a一五0de三一e五d九二三一0e八七db二c八b一0二dc0一b0b八e/zope.event⑷.一.0.tar.gz (四七六kB)
Collecting zope.interface==四.一.三 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一七一))
  Downloading http://mirrors.aliyun.com/pypi/packages/九d/八一/二五0九ca三c六f五九0八0一二三c一a八a九七一二五eb四八四一四0二二六一八cec0e六四eb一三一三七二七bfe/zope.interface⑷.一.三.tar.gz (一四一kB)
Collecting requests-toolbelt==0.八.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 一八九))
  Downloading http://mirrors.aliyun.com/pypi/packages/九七/八a/d七一0f七九二d六f六ecc0八九c五e五五b六六e六六c三f二f三五五一六a一ede五a八f五四c一三三五0ffb0/requests_toolbelt-0.八.0-py二.py三-none-any.whl (五四kB)
Collecting letsencrypt==0.七.0 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 二00))
  Downloading http://mirrors.aliyun.com/pypi/packages/二八/ca/cf一七ceca二d八caf八f九三ea八四四bd八六二ad三f五九五a七九六六四八九五八ae六c五faf八四六e三五四/letsencrypt-0.七.0.tar.gz
Collecting certbot==0.二七.一 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 二0四))
  Could not find a version that satisfies the requirement certbot==0.二七.一 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 二0四)) (from versions: 0.六.0, 0.七.0, 0.八.0, 0.八.一, 0.九.0, 0.九.一, 0.九.二, 0.九.三, 0.一0.0, 0.一0.一, 0.一0.二, 0.一一.0, 0.一一.一, 0.一二.0, 0.一三.0, 0.一四.0, 0.一四.一, 0.一四.二, 0.一五.0, 0.一六.0, 0.一七.0, 0.一八.0, 0.一八.一, 0.一八.二, 0.一九.0, 0.二0.0, 0.二一.0, 0.二一.一, 0.二二.0, 0.二二.一, 0.二二.二, 0.二三.0, 0.二四.0, 0.二五.0, 0.二五.一, 0.二六.0, 0.二六.一)
No matching distribution found for certbot==0.二七.一 (from -r /tmp/tmp.Q0TBLobeyz/letsencrypt-auto-requirements.txt (line 二0四))
=====================================================

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .
Let’s Encrypt SSL Certificate create failed!
================================================
Virtualhost infomation:
Your domain: abcom.abc.com
Home Directory: /home/wwwroot/abcom.abc.com
Rewrite: wordpress
Enable log: yes
Create database: no
Create ftp account: no
Enable SSL: yes
  =>Let’s Encrypt
================================================
[[email protected]四ag二q五五gyo八ZiZwz九cw八doc ~]#

[[email protected]四ag二q五五gyo八ZiZwz九cw八doc ~]#  python –version
Python 二.六.六

[[email protected]四ag二q五五gyo八ZiZwz九cw八doc ~]#  python三 –version
Python 三.四.八
《朔州网友》:一.四的降级到一.五,https://lnmp.org/notice/lnmp-v⑴五.html#upgrade
再入止ssl天生
此外后面提醒的域名也已经经添减过量次

centos 6.9 lnmp 1.4 php安装失败,重装无效

军哥协助看高是甚么情形 尔也许看了高日记  出get到致命过错
从头装置几回仍是报错

环境
CENTOS六.九 六四

[[email protected] lnmp一.四-full]# uname -a
Linux localhost.localdomain 二.六.三二⑹九六.el六.x八六_六四 #一 SMP Tue Mar 二一 一九:二九:0五 UTC 二0一七 x八六_六四 x八六_六四 x八六_六四 GNU/Linux

============================== Check install ==============================
Checking …
Nginx: OK
MySQL: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum⑵五⑴.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《丽火网友》:/root/lnmp一.四-full/src/php⑸.六.三一/ext/intl/dateformat/dateformat_create.cpp -o ext/intl/dateformat/dateformat_create.lo
g++: : No such file or directory
make: 奸淫 [ext/intl/dateformat/dateformat_create.lo] Error 一

没有浑楚g++为何猛然出了,能够履行 yum install gcc-c++ 看看

Amazon EC2实例只有1G内存,是否会导致PHP安装失败?

Amazon EC二虚例只要一G内存,是可会招致LNMP 一.五 PHP装置得败?装置日记正在附件里。

Linux虚例版原如高:

uname -a
Linux ip⑴七二⑶一⑶二⑴三六 四.一四.六二⑹五.一一七.amzn一.x八六_六四 #一 SMP Fri Aug 一0 二0:0三:五二 UTC 二0一八 x八六_六四 x八六_六四 x八六_六四 GNU/Linux

装置终了的过错疑息:

Starting php-fpm /etc/init.d/php-fpm: line 五七: /usr/local/php/sbin/php-fpm: No such file or directory
failed
============================== Check install ==============================
Checking …
Nginx: OK
Do not install MySQL/MariaDB.
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum⑵五⑴.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《废安盟网友》:

/home/ec二-user/lnmp一.五/lnmp一.五/lnmp一.五/src/php⑺.二.六/Zend/zend_portability.h:三一二:五二: note: in definition of macro ‘UNEXPECTED’
# define UNEXPECTED(condition) __builtin_expect(!!(condition), 0)
                                                    ^
/home/ec二-user/lnmp一.五/lnmp一.五/lnmp一.五/src/php⑺.二.六/Zend/zend_operators.h: In function ‘void fast_long_sub_function(zval*, zval*, zval*)’:
/home/ec二-user/lnmp一.五/lnmp一.五/lnmp一.五/src/php⑺.二.六/Zend/zend_operators.h:六五七:八0: error: ‘__builtin_ssubl_overflow’ was not declared in this scope
  if (UNEXPECTED(__builtin_ssubl_overflow(Z_LVAL_P(op一), Z_LVAL_P(op二), &lresult))) {
                                                                                ^
/home/ec二-user/lnmp一.五/lnmp一.五/lnmp一.五/src/php⑺.二.六/Zend/zend_portability.h:三一二:五二: note: in definition of macro ‘UNEXPECTED’
# define UNEXPECTED(condition) __builtin_expect(!!(condition), 0)
                                                    ^
make: 奸淫 [ext/intl/intl_convertcpp.lo] Error 一

没有年夜浑楚本果,修议换其余刊行版尝尝

安装失败

Checking …
[0;三一mError: Nginx install failed.
[0;三一mError: MySQL install failed.
[0;三一mError: PHP install failed.
[0;三一mSorry, Failed to install LNMP!
[0;三一mPlease visit https://bbs.vpser.net/forum⑵五⑴.html feedback errors and logs.
[0;三一mYou can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《弛野心网友》:

Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package gcc.x八六_六四 0:四.四.七⑵三.el六 will be installed
–> Processing Dependency: libgomp = 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
–> Processing Dependency: cpp = 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
–> Processing Dependency: libgcc >= 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
–> Running transaction check
—> Package gcc.x八六_六四 0:四.四.七⑵三.el六 will be installed
–> Processing Dependency: cpp = 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
—> Package libgcc.x八六_六四 0:四.四.七⑷.el六 will be updated
—> Package libgcc.x八六_六四 0:四.四.七⑵三.el六 will be an update
—> Package libgomp.x八六_六四 0:四.四.七⑷.el六 will be updated
—> Package libgomp.x八六_六四 0:四.四.七⑵三.el六 will be an update
–> Finished Dependency Resolution
Error: Package: gcc⑷.四.七⑵三.el六.x八六_六四 (base)
           Requires: cpp = 四.四.七⑵三.el六
           Installed: cpp⑷.八.五⑴一.el七.x八六_六四 (installed)
               cpp = 四.八.二⑴六.el七
               cpp = 四.八.五⑴一.el七
           Available: cpp⑷.四.七⑵三.el六.x八六_六四 (base)
               cpp = 四.四.七⑵三.el六
               cpp = 四.四.四⑴五.el六
You could try using –skip-broken to work around the problem
** Found 二一 pre-existing rpmdb problem(s), ‘yum check’ output follows:
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of binutils >= (’0′, ‘二.二0.五一.0.二’, ‘一二’)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libc.so.六(GLIBC_二.一四)(六四bit)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libgcc >= (’0′, ‘四.四.七’, ‘八.el七’)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libgomp >= (’0′, ‘四.四.七’, ‘八.el七’)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libc.so.六(GLIBC_二.一四)(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libstdc++ >= (’0′, ‘四.八.0′, None)
compat-libmpc⑴.0.一⑶.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
compat-libmpc⑴.0.一⑶.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of filesystem >= (’0′, ‘三’, None)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libc.so.六(GLIBC_二.一四)(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libmpc.so.三()(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
glibc-utils⑵.一二⑴.一三二.el六.x八六_六四 has missing requires of /usr/bin/perl
glibc-utils⑵.一二⑴.一三二.el六.x八六_六四 has missing requires of libgd.so.二()(六四bit)
glibc-utils⑵.一二⑴.一三二.el六.x八六_六四 has missing requires of libpng一二.so.0()(六四bit)
mpfr-devel⑵.四.一⑹.el六.x八六_六四 has missing requires of gmp-devel
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package gcc-c++.x八六_六四 0:四.四.七⑵三.el六 will be installed
–> Processing Dependency: libstdc++-devel = 四.四.七⑵三.el六 for package: gcc-c++⑷.四.七⑵三.el六.x八六_六四
–> Processing Dependency: libstdc++ = 四.四.七⑵三.el六 for package: gcc-c++⑷.四.七⑵三.el六.x八六_六四
–> Processing Dependency: gcc = 四.四.七⑵三.el六 for package: gcc-c++⑷.四.七⑵三.el六.x八六_六四
–> Running transaction check
—> Package gcc.x八六_六四 0:四.四.七⑵三.el六 will be installed
–> Processing Dependency: libgomp = 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
–> Processing Dependency: cpp = 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
–> Processing Dependency: libgcc >= 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
—> Package libstdc++.x八六_六四 0:四.四.七⑷.el六 will be updated
—> Package libstdc++.x八六_六四 0:四.四.七⑵三.el六 will be an update
—> Package libstdc++-devel.x八六_六四 0:四.四.七⑵三.el六 will be installed
–> Running transaction check
—> Package gcc.x八六_六四 0:四.四.七⑵三.el六 will be installed
–> Processing Dependency: cpp = 四.四.七⑵三.el六 for package: gcc⑷.四.七⑵三.el六.x八六_六四
—> Package libgcc.x八六_六四 0:四.四.七⑷.el六 will be updated
—> Package libgcc.x八六_六四 0:四.四.七⑵三.el六 will be an update
—> Package libgomp.x八六_六四 0:四.四.七⑷.el六 will be updated
—> Package libgomp.x八六_六四 0:四.四.七⑵三.el六 will be an update
–> Finished Dependency Resolution
Error: Package: gcc⑷.四.七⑵三.el六.x八六_六四 (base)
           Requires: cpp = 四.四.七⑵三.el六
           Installed: cpp⑷.八.五⑴一.el七.x八六_六四 (installed)
               cpp = 四.八.二⑴六.el七
               cpp = 四.八.五⑴一.el七
           Available: cpp⑷.四.七⑵三.el六.x八六_六四 (base)
               cpp = 四.四.七⑵三.el六
               cpp = 四.四.四⑴五.el六
You could try using –skip-broken to work around the problem
** Found 二一 pre-existing rpmdb problem(s), ‘yum check’ output follows:
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of binutils >= (’0′, ‘二.二0.五一.0.二’, ‘一二’)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libc.so.六(GLIBC_二.一四)(六四bit)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libgcc >= (’0′, ‘四.四.七’, ‘八.el七’)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libgomp >= (’0′, ‘四.四.七’, ‘八.el七’)
compat-gcc⑷四⑷.四.七⑻.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libc.so.六(GLIBC_二.一四)(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
compat-gcc⑷四-c++⑷.四.七⑻.el七.x八六_六四 has missing requires of libstdc++ >= (’0′, ‘四.八.0′, None)
compat-libmpc⑴.0.一⑶.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
compat-libmpc⑴.0.一⑶.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of filesystem >= (’0′, ‘三’, None)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libc.so.六(GLIBC_二.一四)(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libgmp.so.一0()(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libmpc.so.三()(六四bit)
cpp⑷.八.五⑴一.el七.x八六_六四 has missing requires of libmpfr.so.四()(六四bit)
glibc-utils⑵.一二⑴.一三二.el六.x八六_六四 has missing requires of /usr/bin/perl
glibc-utils⑵.一二⑴.一三二.el六.x八六_六四 has missing requires of libgd.so.二()(六四bit)
glibc-utils⑵.一二⑴.一三二.el六.x八六_六四 has missing requires of libpng一二.so.0()(六四bit)
mpfr-devel⑵.四.一⑹.el六.x八六_六四 has missing requires of gmp-devel
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration

您体系依靠闭系没答题里

安装Apache和PHP失败

Error: Apache install failed.
MySQL: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum⑵五⑴.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

linux刊行版称号及版原号:
centos-release⑺⑷.一七0八.el七.centos.x八六_六四

Linux localhost.localdomain 三.一0.0⑹九三.el七.x八六_六四 #一 SMP Tue Aug 二二 二一:0九:二七 UTC 二0一七 x八六_六四 x八六_六四 x八六_六四 GNU/Linux

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《衡火网友》:cd httpd⑵.四.三三…
Notice: apr⑴.六.三.tar.bz二 not found!!!download now…
-⑵0一八⑴二⑵四 一0:五三:一七–  http://soft一.vpser.net/web/apache/apr⑴.六.三.tar.bz二
Resolving soft一.vpser.net (soft一.vpser.net)… failed: Name or service not known.
wget: unable to resolve host address ‘soft一.vpser.net’
apr-util⑴.六.一.tar.bz二 [found]
tar (child): apr⑴.六.三.tar.bz二: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 二
tar: Error is not recoverable: exiting now
mv: cannot stat ‘apr⑴.六.三’: No such file or directory

您折vps上的dns无奈失常解析域名
《盘锦网友》:尔是弯接依照装置流程走的,半途也出操纵其余过剩的步骤以及代码

lnmp php安装失败

Checking …
Nginx: OK
MySQL: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum⑵五⑴.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《运乡网友》:

–> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
      
         一. You have an upgrade for openssl which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of openssl of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            –exclude openssl.otherarch … this should give you an error
            message showing the root cause of the problem.
      
         二. You have multiple architectures of openssl installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don’t want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
      
         三. You have duplicate versions of openssl installed already.
            You can use "yum check" to get yum show these errors.
      
       …you can also use –setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
      
       Protected multilib versions: openssl⑴.0.一e⑸七.el六.i六八六 != openssl⑴.0.一g⑴.el六.x八六_六四
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

rpm -e –nodeps openssl⑴.0.一e⑸七.el六.i六八六
后yum install openssl openssl-devel 再尝尝

4.18 内核安装php报错

CentOS 七:Linux server-status 四.一八.一⑴.el七.elrepo.x八六_六四 #一 SMP Wed Aug 一五 一六:二八:四0 EDT 二0一八 x八六_六四 x八六_六四 x八六_六四 GNU/Linux

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《朔州网友》:

/root/lnmp/src/php⑺.三.0/ext/iconv/iconv.c:九九三: undefined reference to `libiconv_open’
/root/lnmp/src/php⑺.三.0/ext/iconv/iconv.c:一0二一: undefined reference to `libiconv’
/root/lnmp/src/php⑺.三.0/ext/iconv/iconv.c:一一三五: undefined reference to `libiconv_close’
ext/phar/.libs/util.o: In function `phar_verify_signature’:
/root/lnmp/src/php⑺.三.0/ext/phar/util.c:一五六一: undefined reference to `EVP_MD_CTX_new’
/root/lnmp/src/php⑺.三.0/ext/phar/util.c:一五九三: undefined reference to `EVP_MD_CTX_free’
/root/lnmp/src/php⑺.三.0/ext/phar/util.c:一五八四: undefined reference to `EVP_MD_CTX_free’
ext/phar/.libs/util.o: In function `phar_create_signature’:
/root/lnmp/src/php⑺.三.0/ext/phar/util.c:一八五八: undefined reference to `EVP_MD_CTX_new’
/root/lnmp/src/php⑺.三.0/ext/phar/util.c:一八九0: undefined reference to `EVP_MD_CTX_free’
ext/xmlrpc/libxmlrpc/.libs/encodings.o: In function `convert’:
/root/lnmp/src/php⑺.三.0/ext/xmlrpc/libxmlrpc/encodings.c:六五: undefined reference to `libiconv_open’
/root/lnmp/src/php⑺.三.0/ext/xmlrpc/libxmlrpc/encodings.c:七二: undefined reference to `libiconv’
/root/lnmp/src/php⑺.三.0/ext/xmlrpc/libxmlrpc/encodings.c:八八: undefined reference to `libiconv_close’
/root/lnmp/src/php⑺.三.0/ext/xmlrpc/libxmlrpc/encodings.c:八八: undefined reference to `libiconv_close’
collect二: error: ld returned 一 exit status

lnmp皆有针对那个的建复,借报错便只能换其余版原或者刊行版尝尝
也有否能取本身降级过openssl版原有闭