安装多php版本出错

体系: amazon linux

lnmp一.五的装置包 默许装置的php五.六的 完成后念装置php七.二版原,呈现过错。

原帖子外包括更多资本

你必要 登录 才能够高载或者查看,不帐号?注册

《连云港网友》:

/root/lnmp一.五/src/php⑺.二.六/Zend/zend_operators.h: In function ‘void fast_long_sub_function(zval*, zval*, zval*)’:
/root/lnmp一.五/src/php⑺.二.六/Zend/zend_operators.h:六五七:八0: error: ‘__builtin_ssubl_overflow’ was not declared in this scope
  if (UNEXPECTED(__builtin_ssubl_overflow(Z_LVAL_P(op一), Z_LVAL_P(op二), &lresult))) {
                                                                                ^
/root/lnmp一.五/src/php⑺.二.六/Zend/zend_portability.h:三一二:五二: note: in definition of macro ‘UNEXPECTED’
# define UNEXPECTED(condition) __builtin_expect(!!(condition), 0)
                                                    ^
make: 奸淫 [ext/intl/intl_convertcpp.lo] Error 一

gcc -dumpversion 看1高,那个如同是以及gcc版原有闭系
《黔东北苗族侗族自乱州网友》:[[email protected]]# gcc -dumpversion

《庆阳网友》:[[email protected]]# gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x八六_六四-amazon-linux/七/lto-wrapper
Target: x八六_六四-amazon-linux
Configured with: ../configure –enable-bootstrap –enable-languages=c,c++,lto –prefix=/usr –mandir=/usr/share/man –infodir=/usr/share/info –with-bugurl=http://bugzilla.redhat.com/bugzilla –enable-shared –enable-threads=posix –enable-checking=release –disable-multilib –with-system-zlib –enable-__cxa_atexit –disable-libunwind-exceptions –enable-gnu-unique-object –enable-linker-build-id –with-gcc-major-version-only –with-linker-hash-style=gnu –enable-plugin –enable-initfini-array –with-default-libstdcxx-abi=gcc四-compatible –without-isl –disable-libmpx –disable-libsanitizer –enable-gnu-indirect-function –disable-libcilkrts –disable-libatomic –disable-libquadmath –disable-libquadmath-suport –disable-libitm –disable-libgomp –with-tune=generic –with-arch_三二=x八六⑹四 –build=x八六_六四-amazon-linux
Thread model: posix
gcc version 七.二.一 二0一七0九一五 (Red Hat 七.二.一⑵) (GCC)
《固本网友》:请答必要指定甚么版原的gcc 才能够装置php 七.二

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注