军哥,安装失败,请教一下

系统是Centos 6 x86,安装很多次了,一直提示失败

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

《大同网友》:

解决依赖关系
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
–> 执行事务检查
—> Package gcc.i686 0:4.4.7-23.el6 will be 安装
–> 处理依赖关系 cpp = 4.4.7-23.el6,它被软件包 gcc-4.4.7-23.el6.i686 需要
–> 处理依赖关系 glibc-devel >= 2.2.90-12,它被软件包 gcc-4.4.7-23.el6.i686 需要
–> 处理依赖关系 cloog-ppl >= 0.15,它被软件包 gcc-4.4.7-23.el6.i686 需要
–> 执行事务检查
—> Package cloog-ppl.i686 0:0.15.7-1.2.el6 will be 安装
–> 处理依赖关系 libppl_c.so.2,它被软件包 cloog-ppl-0.15.7-1.2.el6.i686 需要
–> 处理依赖关系 libppl.so.7,它被软件包 cloog-ppl-0.15.7-1.2.el6.i686 需要
—> Package cpp.i686 0:4.4.7-23.el6 will be 安装
–> 处理依赖关系 libmpfr.so.1,它被软件包 cpp-4.4.7-23.el6.i686 需要
—> Package glibc-devel.i686 0:2.12-1.212.el6_10.3 will be 安装
–> 处理依赖关系 glibc-headers = 2.12-1.212.el6_10.3,它被软件包 glibc-devel-2.12-1.212.el6_10.3.i686 需要
–> 处理依赖关系 glibc = 2.12-1.212.el6_10.3,它被软件包 glibc-devel-2.12-1.212.el6_10.3.i686 需要
–> 处理依赖关系 glibc-headers,它被软件包 glibc-devel-2.12-1.212.el6_10.3.i686 需要
–> 执行事务检查
—> Package glibc.i686 0:2.12-1.192.el6 will be 升级
–> 处理依赖关系 glibc = 2.12-1.192.el6,它被软件包 glibc-common-2.12-1.192.el6.i686 需要
—> Package glibc.i686 0:2.12-1.212.el6_10.3 will be an update
–> 处理依赖关系 glibc-common = 2.12-1.212.el6_10.3,它被软件包 glibc-2.12-1.212.el6_10.3.i686 需要
—> Package glibc-headers.i686 0:2.12-1.212.el6_10.3 will be 安装
–> 处理依赖关系 kernel-headers >= 2.2.1,它被软件包 glibc-headers-2.12-1.212.el6_10.3.i686 需要
–> 处理依赖关系 kernel-headers,它被软件包 glibc-headers-2.12-1.212.el6_10.3.i686 需要
—> Package mpfr.i686 0:2.4.1-6.el6 will be 安装
—> Package ppl.i686 0:0.10.2-11.el6 will be 安装
–> 执行事务检查
—> Package glibc.i686 0:2.12-1.192.el6 will be 升级
—> Package glibc-common.i686 0:2.12-1.192.el6 will be 升级
—> Package glibc-common.i686 0:2.12-1.212.el6 will be 升级
—> Package glibc-common.i686 0:2.12-1.212.el6_10.3 will be an update
—> Package kernel-headers.i686 0:2.6.32-754.12.1.el6 will be 安装
–> 完成依赖关系计算
错误:Package: glibc-common-2.12-1.192.el6.i686 (@anaconda-CentOS-201605211917.i386/6.8)
          Requires: glibc = 2.12-1.192.el6
          正在删除: glibc-2.12-1.192.el6.i686 (@anaconda-CentOS-201605211917.i386/6.8)
              glibc = 2.12-1.192.el6
          Updated By: glibc-2.12-1.212.el6_10.3.i686 (updates)
              glibc = 2.12-1.212.el6_10.3
          Available: glibc-2.12-1.212.el6.i686 (base)
              glibc = 2.12-1.212.el6
You could try using –skip-broken to work around the problem
** Found 10 pre-existing rpmdb problem(s), ‘yum check’ output follows:
bash-4.1.2-48.el6.i686 is a duplicate with bash-4.1.2-40.el6.i686
centos-release-6-10.el6.centos.12.3.i686 is a duplicate with centos-release-6-8.el6.centos.12.3.i686
12:dhcp-common-4.1.1-63.P1.el6.centos.i686 is a duplicate with 12:dhcp-common-4.1.1-51.P1.el6.centos.i686
glibc-common-2.12-1.212.el6.i686 is a duplicate with glibc-common-2.12-1.192.el6.i686
glibc-common-2.12-1.212.el6.i686 has missing requires of glibc = (’0′, ’2.12′, ’1.212.el6′)
kernel-firmware-2.6.32-754.11.1.el6.noarch is a duplicate with kernel-firmware-2.6.32-642.el6.noarch
libgcc-4.4.7-23.el6.i686 is a duplicate with libgcc-4.4.7-17.el6.i686
nss-softokn-freebl-3.14.3-23.3.el6_8.i686 is a duplicate with nss-softokn-freebl-3.14.3-23.el6_7.i686
setup-2.8.14-23.el6.noarch is a duplicate with setup-2.8.14-20.el6_4.1.noarch
tzdata-2019a-1.el6.noarch is a duplicate with tzdata-2016c-1.el6.noarch

你系统上依赖关系有问题再怎么安装也是不行的

可以尝试 package-cleanup –cleandupes 然后再 yum install gcc 看能否正常安装,如果能正常安装再重新安装lnmp
不行的话就只能换其他版本或linux发行版

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注