lnmp1.5想配置多版本php,安装出错

用的./install.sh mphp

checking whether we are using the GNU C++ compiler… no
checking whether g++ accepts -g… no
checking how to run the C++ preprocessor… /lib/cpp
configure: error: in `/lnmp一.五/src/php⑺.二.五’:
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log’ for more details
make: 奸淫 No targets specified and no makefile found.  Stop.
make: 奸淫 No targets specified and no makefile found.  Stop.
make: 奸淫 No rule to make target `install’.  Stop.
Copy new php configure file…
Modify php.ini……
Install ZendGuardLoader for PHP 七.二…
unavailable now.
Creating new php-fpm configure file…
Copy php-fpm init.d file…
cp: cannot stat ‘/lnmp一.五/src/php⑺.二.五/sapi/fpm/init.d.php-fpm’: No such file or directory
chmod: cannot access ‘/etc/init.d/php-fpm七.二’: No such file or directory
Add php-fpm七.二 service at system startup…
error reading information on service php-fpm七.二: No such file or directory
error reading information on service php-fpm七.二: No such file or directory
+——————————————-+
|    Manager for LNMP, Written by Licess    |
+——————————————-+
|              https://lnmp.org             |
+——————————————-+
Starting LNMP…
Starting nginx…  done
Starting mariadb (via systemctl):  [  OK  ]
Starting php-fpm  done
[0;三一mFailed to install php⑺.二.五, you can download /root/install-mphp七.二.log from your server, and upload install-mphp七.二.log to LNMP Forum.《上饶网友》:本果找到了。
依据日记:error: C++ preprocessor "/lib/cpp" fails sanity check 找到答题解决圆案

    答题的本源是短少需要的C++库。若是是CentOS体系,运转,如高下令解决:
yum install glibc-headers  
  
yum install gcc-c++

Ubuntu体系外,debian.运转下令:
apt-get install build-essential   
  
apt-get install g++  

最初隐示You have successfully install php⑺.二.五
《抚逆网友》:最佳用的lnmp1键包。不之1

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注