PHP 7.1 CentOS 7.3报错

报错实在太长贴不下…参见http://pasted.co/c06b1bc8
系统是天地祥云提供的干净CentOS 7.3(我装了BBR)《沧州网友》:应该和你之前回复https://bbs.vpser.net/thread-15694-1-1.html 这个一个问题,如果是bug就只能等官网修复,但php 5.4- 都已经不再更新
《西双版纳傣族自治州网友》:

原帖由 licess 于 2017-4-23 12:37 发表
应该和你之前回复https://bbs.vpser.net/thread-15694-1-1.html 这个一个问题,如果是bug就只能等官网修复,但php 5.4- 都已经不再更新

这台机器直接用7.1,不知道7.1.5什么时候出来,看描述7.1.5就是专门为了解决这个问题了
另外不用lnmp自带而是通过包管理(yum/dnf)装的MariaDB,能用lnmp database命令么
《南充网友》:/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc: In function ‘void md5_result(MD5_CONTEXT*, uchar*)’:
/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc:86:29: error: ‘EVP_MD_CTX_cleanup’ was not declared in this scope
   EVP_MD_CTX_cleanup(context);
                             ^
/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc: In function ‘void my_md5(uchar*, const char*, size_t)’:
/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc:102:15: error: aggregate ‘MD5_CONTEXT md5_context’ has incomplete type and cannot be defined
   MD5_CONTEXT md5_context;
               ^
/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc: In function ‘void my_md5_multi(uchar*, …)’:
/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc:127:15: error: aggregate ‘MD5_CONTEXT md5_context’ has incomplete type and cannot be defined
   MD5_CONTEXT md5_context;
               ^
/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc: In function ‘size_t my_md5_context_size()’:
/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_md5.cc:140:28: error: invalid application of ‘sizeof’ to incomplete type ‘MD5_CONTEXT {aka evp_md_ctx_st}’
   return sizeof(MD5_CONTEXT);
                            ^
make[2]: *** [mysys_ssl/CMakeFiles/mysys_ssl.dir/my_md5.cc.o] Error 1
make[1]: *** [mysys_ssl/CMakeFiles/mysys_ssl.dir/all] Error 2
make: *** [all] Error 2

MariaDB也无法编译安装
《河源网友》:我用的阿里云ECS  Centos 7.3  64位,完美安装LNMP1.4   并且SSL也都部署上了。

只是不知道1.4版本lnmp vhost add  命令添加网站,同时安装SSL证书 成功以后,SSL证书有没有默认自动续约。

还是需要再执行什么命令,能指定多少天后自动续约SSL证书
《忻州网友》:

原帖由 licess 于 2017-4-24 09:48 发表
只要目录一样的话就可以用

4# 原因不清楚

5#  crontab -l 查看,可以自己修改,但是官方程序会有检测,不到临近的时间也不给续

以后建议在版本选择里加上7.1 latest和latest,方便这种兼容性不好的情况
https://github.com/php/php-src/archive/PHP-7.1.zip

https://github.com/php/php-src/archive/master.zip

《唐山网友》:哪怕是PHP7.2仍然不兼容…

http://pasted.co/c5359220

《晋城网友》:https://bbs.vpser.net/thread-15744-1-1.html

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注